build details

Show: section status errors & todos local changes recent changes last change in-page changes feedback controls

Autolab minimum requirements

Modified 2020-01-20 by AmaurX

A Duckietown up to specifications from the duckietown book (unknown ref opmanual_duckietown/duckietowns)

previous warning next (4 of 8) index
warning
I will ignore this because it is an external link. 

 > I do not know what is indicated by the link '#opmanual_duckietown/duckietowns'.

Location not known more precisely.

Created by function n/a in module n/a.
.

Your software environment is setup.

Prerequisite recommendation

Modified 2020-02-03 by Susanne Keller

If you are building an Autolab, you are a committed developer of Duckietown. We strongly recommend using Ubuntu 18.04. To set up the computer, follow the instructions here.

We suggest that your workflow for software should follow the standard one, using dt-env-developer . This is a meta repository that aggregates, with the myrepos tool, the different repositories of code that developers use daily. To set it up, follow the README instructions. The rest of this book will assume that you set it up this way, but you could also clone each individual repository on its own and use it as usual.